This tutorial provides Java solution to "Equal Stacks" challenge of HackerRank.
Hackerrank Challenge Details
Problem Statement:
You have three stacks of cylinders where each cylinder has the same diameter, but they may vary in height. You can change the height of a stack by removing and discarding its topmost cylinder any number of times.
Find the maximum possible height of the stacks such that all of the stacks are exactly the same height. This means you must remove zero or more cylinders from the top of zero or more of the three stacks until they're all the same height, then print the height. The removals must be performed in such a way as to maximize the height.
Note: An empty stack is still a stack.
Input Format:
The first line contains three space-separated integers, n1, n2, and n3, describing the respective number of cylinders in stacks 1, 2, and 3. The subsequent lines describe the respective heights of each cylinder in a stack from top to bottom:
- The second line contains n1 space-separated integers describing the cylinder heights in stack 1.
- The third line contains n2 space-separated integers describing the cylinder heights in stack 2.
- The fourth line contains n3 space-separated integers describing the cylinder heights in stack 3.
Output Format:
Print a single integer denoting the maximum height at which all stacks will be of equal height.
Sample Input:
5 3 4
3 2 1 1 1
4 3 2
1 1 4 1
Sample Output:
5
Explanation:
Initially, the stacks look like this:
Observe that the three stacks are not all the same height. To make all stacks of equal height, we remove the first cylinder from stacks 1 and 2, and then remove the top two cylinders from stack 3 (shown below).
As a result, the stacks undergo the following change in height:
- 8 - 3 = 5
- 9 - 4 = 5
- 7 - 1 - 1 = 5
All three stacks now have height = 5. Thus, we print 5 as our answer.
Solution Details
Java Implementation:
package com.saintech.allprogtutorials.hackerrank.algos;
import java.util.Scanner;
public class EqualStacks {
/**
* Returns minumum height across all the input stack heights.
*
* @param heights Array containing the height of stacks.
* @return minimum height.
*/
private static int minStackHeight(int[] heights) {
int maxHeight = Integer.MAX_VALUE;
for(int i = 0; i < heights.length; i++) {
maxHeight = Math.min(maxHeight, heights[i]);
}
return maxHeight;
}
/**
* @param heights Array containing the height of stacks.
* @return true if all the elements of input array are equal.
*/
private static boolean areAllElementsEqual(int[] heights) {
int height = heights[0];
for(int hTmp : heights) {
if(height != hTmp) {
return false;
}
}
return true;
}
public static void main(String[] args) {
final Scanner in = new Scanner(System.in);
int n1 = in.nextInt();
int n2 = in.nextInt();
int n3 = in.nextInt();
final int[][] stacks = {new int[n1], new int[n2], new int[n3]};
final int[] heights = {0, 0, 0};
final int[] indexes = {0, 0 ,0};
for(int i = 0; i < stacks.length; i++) {
for(int j = 0; j < stacks[i].length; j++) {
stacks[i][j] = in.nextInt();
heights[i] += stacks[i][j];
}
}
int minHeight = minStackHeight(heights);
while(!areAllElementsEqual(heights)) {
for(int i = 0; i < stacks.length; i++) {
if(heights[i] > minHeight) {
heights[i] -= stacks[i][indexes[i]++];
minHeight = Math.min(minHeight, heights[i]);
}
}
}
System.out.println(minHeight);
in.close();
}
}
Thank you for reading through the tutorial. In case of any feedback/questions/concerns, you can communicate same to us through your comments and we shall get back to you as soon as possible.